Transact

  1. Home
  2. Transact
  3. Features and Functions
  4. Administrator Role and Features
  5. Module/Plugin Configuration
  6. Extraction Module
  7. Nuance Extraction plugin
  8. Form Data Extraction Using Nuance

Form Data Extraction Using Nuance

The NUANCE_EXTRACTION_PLUGIN is part of the Extraction module. You can use the NUANCE_EXTRACTION_PLUGIN to extract:

• Text data
• Checkbox data
• OCR form data
• Hand-written data
• Barcode data

You can also use the NUANCE_EXTRACTION_PLUGIN to extract data in multiple languages. Data extraction through Nuance happens with the help of template files (*.tlz). These template files are created using Nuance Form Template Editor application installed on Windows systems.

Note: Only non-cursive handwritten extraction is supported.

Installing Nuance Form Template Editor

The Nuance Form Template Editor executable is packaged with Ephesoft Linux Installer and can be located at: ApplicationnativeNuance.
User need to install the Nuance Form Template Editor application on a Windows system and utilize the template created through this editor while using the NUANCE_EXTRACTION_PLUGIN in a Linux environment

Activating Nuance Form Template Editor

You can perform online activation using Nuance Licensing Tool both online and offline. The following sections provide you a brief walk through about online and offline activation of Nuance Form Template Editor

Online Activation

Perform the following steps to activate Nuance Form Template Editor online.

1. Launch Nuance Licensing Tool from the Start menu.
This initiates interaction with the Nuance Licensing Server and displays the results in the Status bar.

Image1
Figure 1. Nuance Licensing Tool

If communication with Nuance Licensing Server is successful, then Nuance Licensing Tool displays the licenses found in the license store. It also displays the Hardware Fingerprint (HWFP) of your development system

2. Click File > Download to download the license file and select it.

Note: If you have already downloaded the license file to this system through the Nuance Licensing Tool, select the downloaded license file.

3. Click Functions > Activate.
Upon successful activation, the relevant Activation Date is displayed. Expiration Date is displayed only if you have a temporary license.

Offline Activation

If system does not have internet access, license download and activation can be performed manually. To do this, use a system with internet access and proceed as follows:
1. Open a web browser and go to the following link: http://activation.scansoft.com/download/

Image2
Figure 3. Offline Activation

2. Enter the serial number (s) and click Download licenses to download the license file(s).
3. Using a portable media, transfer the downloaded license file(s) to the target developer system where CSDK is installed.
4. Launch the Nuance Licensing Tool from the Start menu.
5. Click File > Load and load each license file separately.
6. Click File > Prepare Licenses for Manual Activation to zip and save your license file(s).
7. Click Functions > Remove to remove each loaded license separately.
8. Using a portable media, transfer your zipped license file (s) back to the other computer with Internet access.
9. Open a web browser and go to the following link: http://activation.scansoft.com/csdkactivation
10. Follow the instructions on that web page.
11. Download and save the received zipped license file(s) to a portable media and transfer it to the target system.
12. Launch Nuance Licensing Tool on the target system again.
13. Click File > Import to import the zipped license file(s).

Your license(s) display in the Licenses area of Nuance Licensing Tool with relevant Activation Date(s).

Enabling Proxy Settings

If the machine is behind a proxy, then exact proxy settings needs to be enabled in Nuance Licensing Tool. To enable proxy settings:

1. Launch Nuance Licensing Tool from the Start menu.
2. Click Tools > Configuration > Proxy to make the proxy settings.

Image3.png
Figure 4. Proxy Settings

Creating Template Files Using Nuance Form Template Editor

Follow the steps listed in Nuance Form Template Editor to create a template file for your document type.

Configuring Fixed Form Extraction Using Nuance Template File

1. After using the Nuance Form Template Editor to create a template (*.tlz) file, copy the *.tlz file to the following folder: <Ephesoft Directory>/SharedFolders/<your batch class ID>/fixed-form-extraction/<your document type>

You can use the template file (*.tlz) to extract data while using Fixed Form Extraction. Configuring Fixed Form Extraction is similar configuring the KV Extraction Rule. To configure Fixed Form Extraction using Nuance template file:

2. From the Batch Class Management screen, open your batch class.
3. Open your document type.
4. Click Fixed Form Extraction.

The following screen displays.

Image9
Figure 5. Fixed Form Extraction

5. Map the template (*.tlz) file with the relevant pages and click Apply.

The NUANCE_EXTRACTION_PLUGIN is now configured to use the mapped template file to extract data. You can observe the extraction done by NUANCE_EXTRACTION_PLUGIN for the batch instance from the Validation screen.

image10
Figure 6. Sample Validation
image10
Figure 7. Sample Validation cont.

Conclusion

This completes an overview of the NUANCE_EXTRACTION_PLUGIN.

Was this article helpful to you? Yes No